First Time Set up - MAM enrollment is failing in Citrix Endpoint Management

First Time Set up - MAM enrollment is failing in Citrix Endpoint Management

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Article ID: CTX240113

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Updated On:

Description

This scenario is for new cloud set up where new MAM enrollment is failing and user will get "Access to company network is denied".
While browsing NSG URL and after providing credential if you do not get "HTTP Status 404 - Not Found" page but instead we get "Secure Connection Failed" error message which indicates the Store is not loading fine. It means some Session policy / certificate issue on your Gateway. 

Resolution

Added the Root/Intermediate Certs for the MAM LB service and updated the STA with FQDN (instead of IP address).

Problem Cause

The FQDN was not resolving on Gateway for STA because certs were not bound with the LB service.