XenServer - Not Able to Enable HA on Pool

XenServer - Not Able to Enable HA on Pool

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Article ID: CTX240027

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Updated On:

Description

Not able to enable HA on pool.

Resolution

Complete the following steps to resolve the issue:
  1. Delete the Metadata for HA and Statefile for HA VDIs from the SR used for HA Heartbeat, before enabling HA
  2. Check the NTP synchronization, Xen1 host should be unsynchronized, the /etc/ntp.conf should be the server directive had xenserver.pool.ntp.org, set the same used in the others hosts 1.xenserver.pool.ntp.org.
  3. Restart the ntpd daemon on the Xen1 host that was unsynchronized, using:
systemctl restart ntpd
  1. Check the time synchronization in every host of the pool again using:
ntpstat -s
ntpq -p
  1. With the all pool synchronized, try enabling HA again.

Problem Cause

The time synchronization was not working, one host has the NTP configuration wrong, pointing to a non-existent NTP server.
The command:
ntpstat -s
gets the following output in the host misconfigured:
unsynchronised
  time server re-starting
   polling server every 8 s
 

Issue/Introduction

XenServer - Not able to enable HA on pool

Additional Information

How to Change NTP Source on XenServer - https://support.citrix.com/article/CTX121278
How to Configure High Availability Feature in XenServer  - https://support.citrix.com/article/CTX121708/