XenServer - Not Able to Enable HA on Pool
book
Article ID: CTX240027
calendar_today
Updated On:
Description
Not able to enable HA on pool.
Resolution
Complete the following steps to resolve the issue:
- Delete the Metadata for HA and Statefile for HA VDIs from the SR used for HA Heartbeat, before enabling HA
- Check the NTP synchronization, Xen1 host should be unsynchronized, the /etc/ntp.conf should be the server directive had xenserver.pool.ntp.org, set the same used in the others hosts 1.xenserver.pool.ntp.org.
- Restart the ntpd daemon on the Xen1 host that was unsynchronized, using:
systemctl restart ntpd
- Check the time synchronization in every host of the pool again using:
ntpstat -s
ntpq -p
- With the all pool synchronized, try enabling HA again.
Problem Cause
The time synchronization was not working, one host has the NTP configuration wrong, pointing to a non-existent NTP server.
The command:
ntpstat -s
gets the following output in the host misconfigured:
unsynchronised
time server re-starting
polling server every 8 s
Issue/Introduction
XenServer - Not able to enable HA on pool
Additional Information
How to Change NTP Source on XenServer - https://support.citrix.com/article/CTX121278
How to Configure High Availability Feature in XenServer - https://support.citrix.com/article/CTX121708/
Was this article helpful?
thumb_up
Yes
thumb_down
No