XenApp/XenDesktop 7.x: Citrix Studio and Director Report Incorrect LoadIndex for CPU Usage Of A VDA

XenApp/XenDesktop 7.x: Citrix Studio and Director Report Incorrect LoadIndex for CPU Usage Of A VDA

book

Article ID: CTX239964

calendar_today

Updated On:

Description

 

  • In Task Manager or Performance Monitor you notice that the CPU usage for a VDA is higher than what is reported by Citrix Director under "Load Evaluator Index" Tab.
  • You have only configured CPU Usage Load Management GPO to calculate Load Index of a VDA.
  • When you run Get-BrokerMachine , LoadIndex reported based on CPU Usage is less as compared to actual CPU usage on the VDA.

Example. The average CPU usage on a VDA is 95%. However, Get-BrokerMachine powershell cmdlet run on Delivery Controller reports lower LoadIndex value for CPU Usage though ideally it should report full load of 10000 if the  CPU usage on the VDA is more than 90% for 5 minutes.



 

Resolution

Disable the "CPU Usage excluded process priority" GPO Setting in Studio so that the CPU usage attributed to the background processes is also considered for load calculation.

LoadIndex3

Problem Cause

By default the CPU usage attributed to background processes running at "Below Normal" or "Low"  Priority is excluded from the load calculation. This is because the below GPO setting is Enabled by Default.

Loadindex




 

Issue/Introduction

XenApp/XenDesktop 7.x: Citrix Studio and Director Report Incorrect LoadIndex for CPU Usage Of A VDA

Additional Information

https://docs.citrix.com/en-us/workspace-environment-management/current-release/user-interface-description/system-optimization/cpu-management.html

https://docs.citrix.com/en-us/citrix-virtual-apps-desktops/policies/reference/load-management-policy-settings.html