High Disk Space Usage on Citrix ADM Causes MAS GUI Inaccessibility
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Article ID: CTX239421
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Description
- High Disk space usage on Citrix ADM > Unable to login to the ADM through GUI / CLI.
- df -h output shows close to 100% Disk utilization.
- 150GB of disk space was consumed by /var/mps/db_pgsql/data/pg_log.
- The DB log file indicates that lot of error messages related to MAS DB went Read-Replica mode.
- This will cause high disk utilization and API queries which may affect the ADC login as well.
Postgres logs : /var/mps/log/postgresql.log
<127.0.0.1(15925)mpsroot537382018-10-18 06:40:12 GMTmpsdb%ERROR: cannot execute DELETE in a read-only transaction<127.0.0.1(15925)mpsroot537382018-10-18 06:40:12 GMTmpsdb%STATEMENT: DELETE FROM "eventHistory" WHERE id = $1
Resolution
This is the known issue where (TSK0717605)MAS DB goes into the read replica mode during HA failover.
Issue got fixed by manually running the script to make MAS DB as primary DB. It is recommended that users upgrade the HA pair to 12.1 49.37 build where this issue is fixed permanently.
Problem Cause
This is the known issue where Primary DB goes into read replica mode after the HA failover.
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