Workspace App for iOS - Error 'EAP is activated and not supported on iOS' when connecting through Netscaler Gateway

Workspace App for iOS - Error 'EAP is activated and not supported on iOS' when connecting through Netscaler Gateway

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Article ID: CTX239411

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Updated On:

Description

This article is intended for Citrix administrators and technical teams only.

Non-admin users must contact their company’s Help Desk/IT support team and can refer to CTX297149 for more information.

Users are unable to connect using Workspace App for iOS through Netscaler Gateway. The connection with Windows, Mac OS works with the Workspace app. Receiver for iOS also works correctly. If the manual configuration with the URL https://baseurl/citrix/store/discovery is used, the error message: "EAP is activated and not supported on IOS". EAP isn't used on this Gateway. If we use the automatic configuration with the baseURL the following error message is displayed: "Cannot add account" "All stores in the discovery document have been loaded".  In both scenarios it failes to add the account.

Resolution

Changing the Internal beacon URL to something that is not resolvable from external network fixed the issue.

Problem Cause

Beacons are not correctly configured