Unable to Update Machine Catalog Hosted on AWS from Citrix Studio Console

Unable to Update Machine Catalog Hosted on AWS from Citrix Studio Console

book

Article ID: CTX239201

calendar_today

Updated On:

Description

In CDF trace based on Machine template ID: (xxx-yyyyy).
we get an error: IpRange is malformed.

840953    1    47:39.1    31168    27092    1    RemoteHCLServerLog                1    Error    "[AWS]: TaskRunner`1.Run: CloudRunQueue-9 - caught exception PluginUtilities.Exceptions.HostingInfrastructureCommunicationsFailureException: CIDR block Amazon.EC2.Model.IpRange is malformed ---> PluginUtilities.Exceptions.WrappedPluginException: CIDR block Amazon.EC2.Model.IpRange is malformed ---> PluginUtilities.Exceptions.WrappedPluginException: The remote server returned an error: (400) Bad Request. ---> PluginUtilities.Exceptions.WrappedPluginException: The remote server returned an error: (400) Bad Request.
--- End of inner exception stack trace ---
   --- End of inner exception stack trace ---
   --- End of inner exception stack trace ---
   at CloudCommon.CloudPluginBase.PluginMachineManager.InvokeAdapter[TResult](Func`1 cloudAdapterCall)
   at CloudCommon.CloudPluginBase.PluginMachineManager.LocateOrCreateIsolationSecurityGroup(String vpcId)
   at CloudCommon.CloudPluginBase.PluginMachineManager.EstablishIsolationEnvironment(String machineName, String availabilityZoneUid, IList`1 networkIds, IList`1 securityGroupIds, IList`1& isolationNetworkIds, IList`1& isolationSecurityGroupIds)
   at CloudCommon.CloudPluginBase.PluginMachineManager.CreateCompleteVM(String name, IVMMetadata metadata, String serviceOffering, IList`1 securityGroups, IList`1 disks, IVolumeServiceState volumeServiceState, Boolean enableNetwork, INetworkInterfaceDetails networkInterfaceDetails, IHypAvailabilityZone zone, Boolean dedicatedTenancy, Boolean tagVms)
   at CloudCommon.CloudPluginBase.PluginHypervisor.<>c__DisplayClass38_0.<BeginCreateCompleteVM>b__0(PluginMachineManager manager)
   at Citrix.HypervisorCommunicationsLibrary.TaskRunItem`2.Run(T manager)
   at HypervisorsCommon.HCL.TaskRunner`1.Run()"

 

Resolution

After manually removing the "Outbound" rules from AWS console and updating the Machine catalog again the issue is resolved.

Problem Cause

AWS has recently enabled IPv6 security group rules by default on the VPC (Virtual Private Cloud) if it has IPv6 subnet but MCS is not expecting to get an IPv6 subnet and failing to update Machine catalog in Citrix Cloud Studio.
  • MCS creates a security group in AWS called "Citrix.XenDesktop.IsolationGroup-XXXXXXXXXXXXXXXXXXXXXX"
  • This gets created with default VPC rules (all traffic allowed out) MCS requests the current outbound rules on the security group before deleting them. This is where it was failing.

Issue/Introduction

In CDF trace based on Machine template ID, we get an error "IpRange is malformed"