Citrix Workspace App (CWA) or Receiver for Windows launch fails after Install or upgrade with Real-time Media Engine (RTME) installed

Citrix Workspace App (CWA) or Receiver for Windows launch fails after Install or upgrade with Real-time Media Engine (RTME) installed

book

Article ID: CTX238932

calendar_today

Updated On:

Description

After installing or upgrading Citrix Workspace App or Receiver for Windows on an endpoint with the Real-time Media Engine (RTME) installed, resource launch fails for any application or desktop.
This might also happen on endpoints that have Cisco's VXME installed.

CWA or Receiver displays one of the following errors:

Error 1:
 
“You might be having an issue with a Citrix virtual driver (HDX RealTime Media Engine). Contact your system administrator for further assistance.”

User-added image
 
Error 2:
 
“Unable to connect to the server. Contact your system administrator with the following error. SSL Error 4: The operation completed successfully.”

User-added image

Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Resolution

Update: The has been fixed in CWA version 1810

Workaround

Replace the values that are missing from the following Windows registry key on the endpoint with CWA or Receiver installed:
 
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Citrix\ICA Client\Engine\Configuration\Advanced\Modules\ICA 3.0\VirtualDriverEx

[HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Citrix\ICA Client\Engine\Configuration\Advanced\Modules\HDX RealTime Media Engine]
"DriverNameWin32"="RTMEPlugin.dll"
 
[HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Citrix\ICA Client\Engine\Configuration\Advanced\Modules\SOCKSProxyPlugin]
"DriverNameWin32"="SOCKSProxyPlugin.dll"
 
[HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Citrix\ICA Client\Engine\Configuration\Advanced\Modules\UDPGatewayPlugin]
"DriverNameWin32"="UDPGatewayPlugin.dll"


The VirtualDriversEx key should contain the following Value Data:
 
HDX RealTime Media Engine, SocksProxyPlugin, UDPGatewayPlugin

User-added image

Note:- For 32 bit machines “WOW6432Node” is not required

Problem Cause

Issue is caused by a corrupted XML file in CWA or Receiver installer that deletes the Windows registry Value data required by the VirtualDriverEx key.
 
Details:
 
When launching any application or desktop, CWA or Receiver loads the virtual drivers listed in the following Windows registry location:
 
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Citrix\ICA Client\Engine\Configuration\Advanced\Modules\ICA 3.0\VirtualDriverEx

[HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Citrix\ICA Client\Engine\Configuration\Advanced\Modules\HDX RealTime Media Engine]
"DriverNameWin32"="RTMEPlugin.dll"

[HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Citrix\ICA Client\Engine\Configuration\Advanced\Modules\SOCKSProxyPlugin]
"DriverNameWin32"="SOCKSProxyPlugin.dll"

[HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Citrix\ICA Client\Engine\Configuration\Advanced\Modules\UDPGatewayPlugin]
"DriverNameWin32"="UDPGatewayPlugin.dll"


After the CWA or Receiver upgrade, the Value data for VirtualDriverEx key is deleted:
 
User-added image
 
During the launch request, CWA or Receiver fails to find the required registry values and the launch fails.

Issue/Introduction

Citrix Workspace App (CWA) or Receiver for Windows launch fails after Install or upgrade with Real-time Media Engine (RTME) installed.

Additional Information

In the past, it was required to uninstall the Lync Optimization Pack when installing or upgrading Receiver.

Upgrading Citrix Receiver when using Citrix Lync Optimization Pack:

https://support.citrix.com/article/CTX200340