'Unexpected Error, Contact Citrix Support Error ID: XDDS:DFB94D9B' - Unable to Update Machine Catalogs -Citrix Cloud

'Unexpected Error, Contact Citrix Support Error ID: XDDS:DFB94D9B' - Unable to Update Machine Catalogs -Citrix Cloud

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Article ID: CTX238890

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Updated On:

Description

In Citrix Cloud, after updating an image, users are unable to update the machines. Users get a popup noting 'Unexpected Error, Contact Citrix Support'. The error details note Error ID: XDDS:DFB94D9B.

  • Azure Hosting Connection
  • Test Connection test failed
  • No App Registration in Azure related to Citrix App

Resolution

To resolve this issue:

  1. Repair Host Connection to Azure Follow the article: CTX224110 - Manually Granting Citrix Cloud Access to Your Azure Subscription.

  2. Create a new App Registration manually – Get the Application ID and the Secret Key.

  3. Go to the Citrix Cloud and edit the existing Hosting Connection. Select Use Existing.Connection1

  4. Update the Values Application ID and Application Secret.Connection2 


Problem Cause

Lost Host Connection to Azure.
In Azure Registered App was deleted or Expired.

Issue/Introduction

In Citrix Cloud, after updating an image  unable to update the machines. We get a popup noting 'Unexpected Error, Contact Citrix Support'. The error details note Error ID: XDDS:DFB94D9B