WEM agents are not syncing consistently with the WEM broker, only if they are rebooted or if the Norskale Agent Host Service is restarted
book
Article ID: CTX238789
calendar_today
Updated On:
Description
- WEM agents are not syncing consistently with the WEM broker.
- Running command "AgentCacheUtility -refreshcache" does not return any errors, and refreshing the VUEMUIAgent either.
- WEM agents sync only when they are rebooted or if the Norskale Agent Host Service is restarted.
- The Last Connection status on the WEM admin console may show the time when the Agent machine was last rebooted or the last time the Agent was synced with the broker before using Offline only mode .
- On the WEM admin console, when right clicking on the agents under Administration > Agents, all options in the menu are shown grayed out.
- The VUEMRSAV utility located on C:\Program Files (x86)\Norskale\Norskale Agent Host\ directory on the agent machine, may be shown as Disconnected some time after the Offline only mode was enabled.
Resolution
Once the setting "Use Cache Even if Online" from the WEM admin console, the only way to disable it on the agent side is by going to the following registry on the Agent machine:
HKLM\System\CurrentControlSet\Control\Norskale\Agent Host\
The key with name "AgentServiceUseCacheEvenIfOnline" should be shown with value 1, which means that setting is enabled.
Set the value to 0 and restart the Norskale Agent Host Service for the change to take effect.
Then trigger a cache refresh by running the command "AgentCacheutility -refreshcache" and refresh the VUEMUIAgent.
From that moment on, the agent will start to sync with the broker properly and you will confirm that by going to the WEM admin console > Administration > Agents, and refresh the agents.
Or
Re-install the WEM Agent on the machines.
Problem Cause
The setting "Use Cache Even if Online" was enabled on the WEM admin console and applied to the WEM agent. Once this setting is applied to the agents, even if trying to disable it from the WEM admin console again, it will not take effect on the agent side as the agent will be using the local cache only even if online with the Broker as the same setting name says. If the agents are able to connect to the broker consistently without any issue, there is no need to enable the "Use Cache Even if Online" setting.
Was this article helpful?
thumb_up
Yes
thumb_down
No