Problem setting up the User Configuration setup on Citrix Self Service Password Reset "Cannot Access Your Server Address"
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Article ID: CTX238344
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Description
I have installed XenDesktop Self-Service Password Reset. When I run through the "Create User Configuration" wizard, I set up the service Configuration part but on the last screen of the User-Configuration section when I click next I get the error message "Cannot access your server address!". I can ping the server name correctly. I found reference to this error in this document https://docs.citrix.com/content/dam/pdfs/content/docs/en-us/self-service-password-reset/current-release/download.pdf but it says it is something which is fixed in the version I am running.
Resolution
Add a Dword Value SkipConnectionTesting = 1
under HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Citrix\MetaFrame Password Manager.
It will bypass the connection testing. The SSPR functionalities should work fine then.
After adding this registry key, was able to get the user configuration done.
Problem Cause
Connection testing might fail when TLS 1.2 is enforced in the environment.
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