Virtual Desktop 7.15 - Citrix Studio stuck at Expanding

Virtual Desktop 7.15 - Citrix Studio stuck at Expanding

book

Article ID: CTX238310

calendar_today

Updated On:

Description

Unable to perform any kind of administrative activity

Environment

The above mentioned sample code is provided to you as is with no representations, warranties or conditions of any kind. You may use, modify and distribute it at your own risk. CITRIX DISCLAIMS ALL WARRANTIES WHATSOEVER, EXPRESS, IMPLIED, WRITTEN, ORAL OR STATUTORY, INCLUDING WITHOUT LIMITATION WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, TITLE AND NONINFRINGEMENT. Without limiting the generality of the foregoing, you acknowledge and agree that (a) the sample code may exhibit errors, design flaws or other problems, possibly resulting in loss of data or damage to property; (b) it may not be possible to make the sample code fully functional; and (c) Citrix may, without notice or liability to you, cease to make available the current version and/or any future versions of the sample code. In no event should the code be used to support ultra-hazardous activities, including but not limited to life support or blasting activities. NEITHER CITRIX NOR ITS AFFILIATES OR AGENTS WILL BE LIABLE, UNDER BREACH OF CONTRACT OR ANY OTHER THEORY OF LIABILITY, FOR ANY DAMAGES WHATSOEVER ARISING FROM USE OF THE SAMPLE CODE, INCLUDING WITHOUT LIMITATION DIRECT, SPECIAL, INCIDENTAL, PUNITIVE, CONSEQUENTIAL OR OTHER DAMAGES, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. Although the copyright in the code belongs to Citrix, any distribution of the sample code should include only your own standard copyright attribution, and not that of Citrix. You agree to indemnify and defend Citrix against any and all claims arising from your use, modification or distribution of the sample code.

Resolution

Please validate the below steps to fix this kind of issue.
1. Verify the Citrix Configuration Service is running, If not running try to start the Service and check launching the Studio
2. Delete the Studio MMC cache under %Appdata%\Microsoft\MMC and check launching the Studio
3. Open PowerShell in admin elevated mode and run the below commands to check the Service status
asnp citrix*
gcm *servicestatus
Copy below commands from Name section
Get-AcctServiceStatus
Get-AdminServiceStatus
Get-AnalyticsServiceStatus
Get-AppLibServiceStatus
Get-BrokerServiceStatus
Get-ConfigServiceStatus
Get-EnvTestServiceStatus
Get-HypServiceStatus
Get-LogServiceStatus
Get-MonitorServiceStatus
Get-OrchServiceStatus
Get-ProvServiceStatus
Get-SfServiceStatus
Get-TrustServiceStatus
Paste under PowerShell command and validate the ServiceStatus: All services status should show OK, If any of the service shows  error validate the relevant service is running under Services console and try to restart the service
4. Validate events on the server and fix if any errors related to database
5. Run Get-BrokerController and check the LicenseServerState should show OK ; If it is in failed state, validate the License server and try to restart the License server and re-run the Get-BrokerController command and validate the LicenseServerState for all controllers listed 
6. Verify If any Antivirus software is blocking connections to Database or License server
 

Problem Cause

Database deadlocks or License Server Issues

Issue/Introduction

Unable to launch Citrix Studio