Access denied error for end users

Access denied error for end users

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Article ID: CTX238203

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Description

End users are not able to launch apps since the user updated controllers. They receive error "Access Denied"

 

Resolution

Run Get-BrokerController and check the state of the controller. If the controller state is "Transitioning", then Follow below steps.


Once the state of the controller is verified to be "Transitioning", Go to Database server and locate the site database. Expand Tables and look for "chb_config.Site". Right click on it and select top 1000 rows.

Delete everything from the table till FROM.

Run command 

Update [SitedatabaseName]. [chb_config].[Site]  
Set BaseOU=Null

Reboot all the controllers.
 

Problem Cause

While performing upgrade on introducing new controller, the controller are not fully upgraded in the Site DB.

Issue/Introduction

User Launching any application gets error "Access Denied"