Logon process to VDAs is extremely slow when Citrix UPM is enabled

Logon process to VDAs is extremely slow when Citrix UPM is enabled

book

Article ID: CTX238012

calendar_today

Updated On:

Description

Logon to VDAs is extremely slow when Citrix UPM is enabled. When disabling the Citrix UPM service the logon process is normal. Sophos AV 10.x is installed on the VDAs.

Resolution

After uninstalling Sophos AV from the VDA the logon process is normal. The recommendation from Sophos AV is to implement the following registry key:

Path: HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Sophos\SavService\Application
Type: REG_DWORD
Name: DisableAsyncScans
Value: 1

Also implement the Citrix AV Exclusions recommended at Citrix Blogs - Citrix Recommended Antivirus Exclusions .

If issue persists then customer should engage Sophos AV Support to have assistance.


Problem Cause

The Issue is not related to Citrix. The cause of the issue is related to Sophos AV which is installed on the VDA as they added an update in version 10.7.6 Sophos AV software release that does asynchronous scanning (Just-In-Time scanning) in addition to the regular scanning. Citrix implementations do not play nice with this setting, and as a result it causes numerous problems.