XenApp/XenDesktop 7.15 CU2: Application Launch Fails With Error "Cannot connect to the Citrix XenApp server.protocol Driver"

XenApp/XenDesktop 7.15 CU2: Application Launch Fails With Error "Cannot connect to the Citrix XenApp server.protocol Driver"

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Article ID: CTX237981

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Updated On:

Description

Published applications fail to launch with below error:

"Unable to launch your application. Contact your help desk with the following information:
Cannot connect to the Citrix XenApp server.protocol Driver error"


VDI's fail to launch with below error:
 
"The connection to "VOA Win 7 LTSR" failed with status (Unknown client error 1110)."

Issue occurs under following conditions:

  • VDA version is 7.15 LTSR CU2.
  • "DHParaml” key under Hkey_Local_Machine\System\CurrentControlSet\Control\Citrix\Security is not present
  • Setting "Enable Secure ICA" is checked in the Delivery group properties.


 

Resolution

A private fix LD0117 is available for Citrix VDA version 7.15 LTSR CU2. Please contact Citrix Technical Support to validate if the issue is same as LD0117 which may need them to capture and analyze the traces post which the private fix can be requested.

Problem Cause

In a clean installation, when we try to connect with 128-but encryption, PDCRYPT2 fails because it can't read the encryption keys from the registry.