Some Receiver Components Fail to Install and Function After Windows 10 Update

Some Receiver Components Fail to Install and Function After Windows 10 Update

book

Article ID: CTX237817

calendar_today

Updated On:

Description

This article is intended for Citrix administrators and technical teams only.
 
Non-admin users must contact their company’s Help Desk/IT support team and can refer to CTX297149 for more information.



After upgrading Windows 10 to a new feature update and attempting to install Citrix Receiver or the Citrix Workspace App, installation will complete successfully, however you will receive errors during the installation process. After that, certain features such as Single Sign On and others may not work as they weren't able to complete their individual component installations.

Environment

Citrix is not responsible for and does not endorse or accept any responsibility for the contents or your use of these third party Web sites. Citrix is providing these links to you only as a convenience, and the inclusion of any link does not imply endorsement by Citrix of the linked Web site. It is your responsibility to take precautions to ensure that whatever Web site you use is free of viruses or other harmful items.

Resolution

Microsoft has published an article advising of this issue and has also provided steps on how to resolve it within Windows. After following the steps outlined in this article and attempting to install Citrix Receiver or the Citrix Workspace App, the installation will complete successfully without any errors and full functionality of the desktop app will be available.

Please see the Additional Resources section for a link to the Microsoft Support article that will resolve this issue.


Problem Cause

There is a known Windows 10 issue that can also affect Citrix Receiver/Workspace App installations due to Single Sign-On components needing to have access to certain information regarding the Network Provider Order settings available in the system registry, which was not there after the OS had been upgraded.

Additional Information

https://support.microsoft.com/en-ie/help/4013822/network-provider-settings-are-removed-during-an-in-place-upgrade-to-wi