Getting an Error: (NMAS)Citrix Application Delivery Management Database requires Maintenance

Getting an Error: (NMAS)Citrix Application Delivery Management Database requires Maintenance

book

Article ID: CTX237760

calendar_today

Updated On:

Description

Error: NetScaler MAS database requires maintenance

Resolution

  1. Log  into MAS as nsrecover /password of nsroot user.

  2. Run the following command to start the Database Maintenance script:
    nohup python /var/db_maintenance.py >/var/mps/log/maintenance.py.log&

  3. Run the following command to monitor the status and complete status of the logs:
    tail -f /var/mps/log/db_maintenance.py.log /var/mps/maintenance.py.log 

    Once maintenance finish you will see these lines at the end of the maintenance log:
    [DEBUG] runCleanup returned result: 0
    [DEBUG] *************** CLEAN UP IS DONE *********************** 

     
    Note: Do not restart the system until the maintenance is completed

  4. After the maintenance is completed, upgrade the mas using the ./installmas command. See steps below for upgrade to ADM 12.1_50.39.
    >> Connect to ADM using any secure copy tool [i.e. Filezilla, WinSCP, etc.]
    >> Navigate to /var/mps/mps_images/
    >> If you see the directory mas-12.1-50.39/ or the file build-mas-12.1-50.39.tgz were a good; otherwise, copy the file over.
    >> Connect to ADM using any SSH tool [PuTTY, SecureRT, etc] and type the following commands:
    > shell
    # cd /var/mps/mps_images/
    # mkdir mas-12.0-50.39     *** Only needed if the directory doesn't exist already ***
    # tar zxvfp build-mas-12.1-50.39.tgz -C mas-12.0-50.39   *** Only needed if you had to copy the file over the ADM. ***
    # cd mas-12.0-50.39/
    # ./installmas

     


Problem Cause

Database Maintenance required.

Issue/Introduction

While upgrading the MAS to 12.1 version we get the error "Netscaler MAS Database requires maintenance"