"Error Id: XDMI:2B7BAC22" when Installing VDA 7.15
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Article ID: CTX237433
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Updated On:
Description
"Error Id: XDMI:2B7BAC22" when installing VDA 7.15
Environment
Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.
Resolution
Follow below steps to resolve this issue:
1.Uninstall all C++ runtime and .NET installed before.
2.Clean registry key via msiexec.exe /x GUID which can be found in HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Uninstall.
3.Install Microsoft update packages.
4.Manually stop all services related to XenApp 6.5.
5.Manually install TelemetryServiceInstaller_x64 in XenApp and XenDesktop 7.15 install media under E:\x64\Virtual Desktop Components. If failed, follow system requirements to enable .Net has been right installed.
6.Once TelemetryServiceInstaller_x64 can be installed successfully, install the VDA.
Problem Cause
Registry keys and programs installed by XenApp 6.5 were not cleaned up.
Issue/Introduction
Cannot install VDA 7.15 successfully with "Error Id: XDMI:2B7BAC22"
Additional Information
VDA for Server OS 7.15 LTSR system requirements: https://docs.citrix.com/en-us/xenapp-and-xendesktop/7-15-ltsr/system-requirements.html#virtual-delivery-agent-vda-for-server-os
How to manually uninstall VDA components: https://support.citrix.com/article/CTX140535
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