NetScaler MAS Not Showing SSL Insight Data

NetScaler MAS Not Showing SSL Insight Data

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Article ID: CTX237065

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Updated On:

Description

Any SSL load balancer, content switching or NetScaler Gateway does not display SSL Insight data.

Resolution

SSL Insight have specific settings and prerequisites that needs to be meet before this feature work, make sure the items below are completed:

Self-service diagnostics for Analytics

Citrix ADM version 12.1 build 49.37 and above has self-service diagnostics for Analytics which is used to identify the license and configuration issues on the managed instances which could lead to no data being captured. The self-service diagnostics helps you to identify and troubleshoot the issues faster. For more information refer to Citrix Documentation - Self-service diagnostics for Analytics.

Prerequisites

  • The NetScaler instance on which you intend to configure SSL Insight must be running a NetScaler software release no earlier than 11.1 build 51.21.
  • The NetScaler MAS version should be no earlier than the NetScaler software version.

Configuring SSL Insight

SSL Insight Metrics are included in Web Insight reports if you enable the following elements:

  1. Enable AppFlow for Web Insight on each NetScaler instance.
  2. Enable ULFD mode on each NetScaler instances. (In some scenarios after enabling ULFD a reboot may be required to really trigger this feature)

    From GUI:
    Navigate to ( System > Settings > Modes and Features > Configure Modes > Checkbox ULFD

    From CLI:
    enable ns mode ULFD

  3. Enable required AppFlow parameters on each NetScaler instance from NMAS.

Problem Cause

Prerequisites not meet
ULFD disabled
MAS version older than Instance version 

Issue/Introduction

Any SSL load balancer, content switching or NetScaler Gateway does not display SSL Insight data.

Additional Information

Citrix Documentation - SSL Insight