Schedule reboot does not restart machines and it stays in Shutdown state in Virtual App - 7.15 LTSR
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Article ID: CTX237058
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Updated On:
Description
When Delivery Group scheduled time for reboot hits some VDAs reboot normally but others remain in Shutdown state until they are manually turned on.
Environment
Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.
Resolution
Create following registry keys on controllers :
Registry Path : HKLM\Software\Citrix\DesktopServer\SiteServices
Name : MaxShutdownTimeSecs
Type : REG_DWORD
Data : 1800 (Decimal)
Default : 20 (sec)
Registry Path : HKLM\SOFTWARE\Citrix\DesktopServer\RebootSchedule
Name : MaxShutdownDelayMin
Type : REG_DWORD
Data : 60 (Decimal)
Default : 10
Info: Minutes Minimum=1 Maximum=60
Registry Path : HKLM\SOFTWARE\Citrix\DesktopServer\RebootSchedule
Name : ShutdownTimeoutRecovery
Type : REG_DWORD
Data : 1 (Decimal)
Problem Cause
The duration it is taking to shutdown the VDA is exceeding timeout value.
i.e. On "initiate Shutdown" from DDC the Hypervisor gets the "Turn Off VM" command.
If it takes longer than the default timeout, it can never send a turn on command for that VDA.
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