Error XDDS:90D86931 in Citrix Studio - "An item with the same key has already been added"
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Article ID: CTX237024
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Updated On:
Description
When browsing the Host Connections or Catalogs in Citrix Studio, the following error is shown.
Clicking on the "View error details" button will show more detailed information as follows:
The same error text can be seen by running the Get-HypHypervisorPlugin command in a PowerShell window.
Resolution
This issue can be seen when there are duplicate folders in the Hypervisor Plugins folder on the DDC (desktop Delivery Controller).
The Hypervisor Plugins directory path will vary depending on the version of the DDC, but in general it should follow this format:
"C:\Program Files\Common Files\Citrix\HCLPlugins\Hypervisor\vN.NN.N.N"
where
vN.NN.N.N represents the version of the Hypervisor Plugins folder. For example v2.23.0.0.
The following steps can be used to correct the issue.
Warning:
The following steps include stopping services that are critical to brokering connections to Citrix Applications and Desktops
During the process, new connections to Applications and Desktops will be impacted
It is strongly recommended to perform these steps during a downtime window in which the impact will be minimal
If Citrix Studio is currently open, please close it.
- Stop the Host, MachineCreation and Broker services on the DDC
- Open a Powershell Window as Administrator
- Execute the following:
Get-Service CitrixHostService,CitrixMachineCreationService,CitrixBrokerService | Stop-Service
- Remove the duplicate plugin folder from the "C:\Program Files\Common Files\Citrix\HCLPlugins\Hypervisor\vN.NN.N.N" Hypervisor Plugins directory.
- Re-register all the existing Hypervisor plugins
- Open a CMD prompt as Administrator
- Navigate to the HCL Plugins base directory:
cd "C:\Program Files\Common Files\Citrix\HCLPlugins" - Execute the following command, taking care to replace the vN.NN.N.N with the actual version of the Hypervisor Plugins:
RegisterPlugins.exe -PluginsRoot "C:\Program Files\Common Files\Citrix\HCLPlugins\Hypervisor\vN.NN.N.N"
- Start the Host, MachineCreation and Broker services on the DDC
- Return to the Powershell Window
- Execute the following:
Get-Service CitrixHostService,CitrixMachineCreationService,CitrixBrokerService | Start-Service
Repeat these steps on all the DDCs in the Site on which the duplicate Plugin folder is found.
Problem Cause
These behavior might be experienced when there are duplicate Hypervisor Plugin folders present on the DDC.
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