XenDesktop 7.18: New machine catalog creation fails with error 'Logging error'

XenDesktop 7.18: New machine catalog creation fails with error 'Logging error'

book

Article ID: CTX236971

calendar_today

Updated On:

Description

In XenDesktop 7.18, new MCS catalog creation may fail with the error 'Logging error' as shown in the screenshot below -

User-added image
Clicking on view details presents with verbose error as shown below -

Error Id: XDDS:CA90918F
Exception:
    Citrix.Console.Models.Exceptions.ScriptException Logging error. Contact Citrix Support.
       at Citrix.Console.PowerShellInteraction.CmdletExecutionMethods.CreateException[T](ICommonLog logger, ExecutionResults`1 results, ICmdletExecutionHost host)
       at Citrix.Console.PowerShellInteraction.CmdletExecutionMethods.Execute[T](ISdkCmdlet`1 sdkCmd, ICmdletExecutionHost host, Boolean allowFailover)
       at Citrix.Console.PowerShellSdk.ProvisioningSchemeService.BackgroundTasks.IdentityPoolCreationTask.CreateIdentityPoolName(IdentityPoolModel identityPoolProperties)
       at Citrix.Console.PowerShellSdk.BackgroundTaskService.BackgroundTask.Task.Run()
   
    DesktopStudio_ErrorId : ConfigurationLoggingError
    Exception : Citrix.ConfigurationLogging.Client.ConfigurationLoggingException: Failed to log low level operation start ---> System.FormatException: Index (zero based) must be greater than or equal to zero and less than the size of the argument list.
       at System.Text.StringBuilder.AppendFormatHelper(IFormatProvider provider, String format, ParamsArray args)
       at System.String.FormatHelper(IFormatProvider provider, String format, ParamsArray args)
       at System.String.Format(IFormatProvider provider, String format, Object[] args)
       at Citrix.ConfigurationLogging.Client.LowLevelOperationScope.StartLowLevelOperation(LowLevelOperationInfo operationInfo)
       at Citrix.ConfigurationLogging.Client.LowLevelOperationScope.StartOperation()
       --- End of inner exception stack trace ---
       at Citrix.ConfigurationLogging.Client.LowLevelOperationScope.StartOperation()
       at Citrix.ConfigurationLogging.Client.LoggingFactory.CreateLowLevelOperation(IConfigurationLoggingEndpoint loggingEndpoint, IWcfConnectionService wcfConnection, IResourcesService resources, LowLevelOperationInfo operationInfo, String source, String sourceSdk, ConfigurationLoggingSettings loggingSettings, Action`2 loggingErrorCallback, Boolean noStopOnDispose, Boolean logDetailsOnLowLevelStop)
       at Citrix.ConfigurationLogging.Client.ConfigurationLoggingProvider.StartLoggableOperation(LowLevelOperationInfo operationInfo, Boolean noStopOnDispose)
       at Citrix.ADIdentity.Logic.ADIdentityLogic.NewIdentityPoolParameterized(NewIdentityPoolParameters parameters, IdentityPool& identityPoolObject)
       at Citrix.Fma.Sdk.ServiceCore.ServiceCore.CheckedCall[T](String name, Func`1 operation, Func`2 defaultValue, Enum code)
    Reason : ConfigurationLoggingException
    Message : Failed to log low level operation start
    Sdk Error Message : The operation could not be performed because of a configuration logging error.
    Sdk Error ID : Citrix.XDPowerShell.Status.ConfigurationLoggingError,Citrix.ADIdentity.Sdk.Commands.NewAcctIdentityPoolCommand
    ErrorCategory : NotSpecified
    DesktopStudio_PowerShellHistory : Create Machine Catalog 'Test123456'
    7/30/2018 3:30:00 PM

Resolution

For a workaround, follow the steps below:
  1. Launch Citrix Studio
  2. In the left pane, navigate to Logging
  3. Under the Actions tab, click Preferences
  4. Under Logging security, select 'Allow changes to the site configuration when the database is not available'

This issue has been resolved in CVAD Release 1811/7.20.

Problem Cause

This issue can occur if logging security is set to 'Prevent changes to the site configuration when the database is not available'

Additional Information

Citrix Engineering reference LD0133 / OFIMPORT-895.