Troubleshooting NetScaler SD-WAN Link Quality

Troubleshooting NetScaler SD-WAN Link Quality

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Article ID: CTX236833

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Description

There are network and WAN connectivity issues when traffic goes through NetScaler SD-WAN.

Resolution

Complete the following steps to resolve this issue:

Step 1: Bypass NetScaler SD-WAN completely (Alter Physical connectivity OR FTW (works only if Inline)

  • Download and Install iPerf if not already present on test client machine. https://iperf.fr/iperf-download.php
  • Use one of the Citrix public facing iPerf servers OR public iPerf servers https://iperf.fr/iperf-servers.php
  • Make sure the iperf client/server version match.
  • Use iperf UDP port 4980 for the tests.
  • Verify Bandwidth and Losses are as expected.

Step 2: Restore NetScaler SD-WAN connectivity

To isolate issues specific to a particular WAN Link, selectively enable one WAN Link at a time. Physically disconnect other WAN Links, OR disable the switch ports.

  • Make sure the WAN Links speed and type is configured correctly.
  • Make sure the subnet/routes/gateway ip is configured correctly.
  • Make sure corresponding Virtual Path(s) are up and running.
  • Perform Reachability Test
  • Perform iPerf tests and verify Bandwidth and Losses on the link.
NetScaler SD-WAN v9.2 onwards has inbuilt tool to run IPERF called – Diagnostics Tool
 

Problem Cause

This issue is caused by misconfiguration of WAN links bandwidth, speed or network settings.

Issue/Introduction

There are network and WAN connectivity issues when traffic goes through NetScaler SD-WAN.