Case Study: Disconnected ICA Sessions Do Not Reconnect To The Same Server

Case Study: Disconnected ICA Sessions Do Not Reconnect To The Same Server

book

Article ID: CTX236353

calendar_today

Updated On:

Description

Disconnected ICA session do not reconnect to the same VDA rather a new ICA session gets created on a different VDA.
 

Resolution

In the PATH Environment variable, move the  location of the third party software Informatica variables after the XenApp/Xendesktop variables. After the change, XenApp/Xendesktp locate the correct version of cmstart.exe

%SystemRoot%\system32;%SystemRoot%;%SystemRoot%\System32\Wbem;%SYSTEMROOT%\System32\WindowsPowerShell\v1.0\;C:\Program Files (x86)\Citrix\system32;C:\Informatica\9.5.0\clients\DT\bin\cmstart.exe

Problem Cause

  • From CDF Traces collected from VDA we could see that LogonComplete was not being logged for the session.
  • Wfshell.exe is supposed to log LogonComplete for the session. From the CDF Traces we found that Wfshell.exe was not loaded for any of the sessions
  • Cmstart.exe is responsible for loading Wfshell.exe.
  • From the CDF Traces we found that cmstart.exe was actually being loaded from c:\Informatica\9.5.0\clients\DT\bin\cmstart.exe instead of C:\Program Files (x86)\Citrix\system32\cmstart.exe.

2018/05/16 15:51:25:60087,28408,12104,-1,MfApHook,\,413,DllMain,7,TC_HOOK_LOAD,"MFAPHOOK: Loading into process c:\Informatica\9.5.0\clients\DT\bin\cmstart.exe
 
  • Since third party cmstart.exe did not load Wfshell.exe,  the logon was not being marked as complete and hence the session was not reconnected to the the same disconnected session.

Note

Some third party software installations like Informatica utilize an executable file named cmstart.exe and modify the environment variables to point to their executable. Because XenApp/XenDesktop also use an executable named cmstart.exe located at C:\Program Files (x86)\Citrix\system32\cmstart.exe for the launch of published applications, it might confuse and locate and launch cmstart.exe of the third party software instead.


One common reason for XenApp/XenDesktop to locate the wrong cmstart.exe is because the third party software might have modified the environment path variables and put the path of its own cmstart.exe before Citrix's cmstart.exe.  Hence the variables provided by the third party software gets priority and that result's in launching third party cmstart.exe instead of Citrix smstart.exe  during the logon process.

This is the default environment path variable before the third party software Informatica installation :

%SystemRoot%\system32;%SystemRoot%;%SystemRoot%\System32\Wbem;%SYSTEMROOT%\System32\WindowsPowerShell\v1.0\;C:\Program Files (x86)\Citrix\system32


This is the modified environment path variable after the third party software Informatica installation :

C:\Informatica\9.5.0\clients\DT\bin\cmstart.exe;%SystemRoot%\system32;%SystemRoot%;%SystemRoot%\System32\Wbem;%SYSTEMROOT%\System32\WindowsPowerShell\v1.0\;C:\Program Files (x86)\Citrix\system32
 

Issue/Introduction

Disconnected ICA Sessions Do Not Reconnect To The Same Server

Additional Information


Application Launch Error: "The Citrix server is unable to process your request to start this published application at this time."
https://support.citrix.com/article/CTX132243