"Cannot complete request" when logging on via NetScaler using dual factor authentication and SSON to StoreFront Server 3.14
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Article ID: CTX236210
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Updated On:
Description
After configuring a remote portal with StoreFront servers load balanced with NetScaler, a user authenticates and they get the error "Cannot complete your request".

From the event Viewer logs of the StoreFront (SF) server:
"An error occurred while using SSL configuration for endpoint 0.0.0.443. The error status code is contained within the returned data "
Environment
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Resolution
The certificate hash shown did not match the one binding to the SSL port 443 in IIS (correct cert hash starts with 89BA19BD4...)
Delete the legacy certificate causing errors via CLI command
Netsh http delete sslcert ipport=0.0.0.0:443
Note: The legacy certificate was associated with another set of StoreFront servers (3 SF servers) instead of the new certificate created for this new set of 2 SF servers.
Validation
When issuing the CLI command:
"netsh http show sslcert" - we now see that the certificate is gone
When testing logging on to the NetScaler, we were able to SSON to SF server using the 2 factor authentication in place and keeping the setting "Enable Loopback Communication" set to ON (Under SF - Edit Receiver for Web Site - Advanced Settings)
Problem Cause
A legacy certificate hash was being cached and used by the new StoreFront servers.
Also, there could be multiple reasons behind "cannot complete request" error message,
- Callback failure on SF server.
- Remote access not enabled.
- Domain name not configured properly.
- Domain name not trusted.
Issue/Introduction
Getting "Cannot complete request" when logging on via Netscaler using dual factor authentication and SSON to StoreFront Server 3.14
Event Viewer logs event id 15021 source: HttpEvent; logname :system; level Error
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