After Upgrade to WEM 4.6 agents not getting configurations with error: Agent (Agent name) is not bound to any configuration set
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Article ID: CTX236109
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Updated On:
Description
Upgrade WEM environment from 4.5 to 4.6. After upgrading, WEM agents are randomly reported with the following different status under Administration > Agents > Registrations: "Agent <AgentHostName> is bound to multiple configuration sets."

Then the same agents are reported with the following status: "Agent <AgentHostName> is not be bound to any Configuration Set."
Other times the same Agents are reported to be bound to the correct configuration set where they belong. Some minutes later the same error messages are shown again repeatedly.
This causes that WEM agents cannot register successfully with the WEM servers.
This issue only happens when using OUs as AD objects in Configuration Sets.
Environment
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Resolution
First workaround is Add Agents per machine AD account and not per OU, or apply the private fix.
This issue is already addressed which is going to be Fixed in the next release WEM 4.7
Problem Cause
In this bug scenario, when searching a specific OU using Parallel way, it will actually return repeated OUs for distinct OU Guids
Issue/Introduction
Upgrade WEM environment from 4.5 to 4.6. After upgrading, WEM agents are randomly reported with the following different status under Administration > Agents > Registrations: "Agent
is bound to multiple configuration sets."
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