Error: "Cannot Complete Your Request" Due to DNS Misconfiguration on Citrix Gateway

Error: "Cannot Complete Your Request" Due to DNS Misconfiguration on Citrix Gateway

book

Article ID: CTX235882

calendar_today

Updated On:

Description

The following error is displayed due to DNS misconfiguration on CitrixGateway:
Cannot Complete Your Request

Resolution

Check the status of the Name Servers configured on Citrix Gateway. Go to Traffic Management > DNS > Verify if Name servers are added and if they are UP.

Complete the following steps to further troubleshoot this issue:

  1. Check reachability of StoreFront, Citrix Gateway, Desktop Delivery Controller and Secure Ticket Authority by pinging the FQDNs if these servers from ADC's CLI and StoreFront.
  2. On the StoreFront server open the Command Prompt > Ping Citrix Gateway FQDN and confirm it resolves to the correct gateway IP address.
  3. Open the StoreFront MMC and go to Manage Citrix Gateway > select the gateway you are configuring > Authentication settings, confirm the Callback URL FQDN listed resolves to the NetScaler Gateway VIP by using the ping command on the Command Prompt from the StoreFront server. Note: Callback URL is only needed if SmartAccess CVAD policies or password-less authentication methods (Smart Cards, SAML, and so on) are used. Or you should leave it as blank.
  4. When a single FQDN configuration is used then refer to the following Citrix Documentation to verify if any step is skipped or misconfigured - Create a single Fully Qualified Domain Name (FQDN) to access a store internally and externally.
  5. Verify if FQDN of STA server is resolvable. If not, change the STA server FQDN to IP address on StoreFront and NetScaler. For more information refer to Citrix Documentation - Configuring the Secure Ticket Authority on NetScaler Gateway.

Problem Cause

This issue is caused due to DNS misconfiguration on NetScaler Gateway.

Issue/Introduction

The following error is displayed due to DNS misconfiguration on NetScaler Gateway: Cannot Complete Your Request

Additional Information