Randomly the Citrix Studio console takes a long time to list Machine Catalogs or Delivery groups

Randomly the Citrix Studio console takes a long time to list Machine Catalogs or Delivery groups

book

Article ID: CTX235871

calendar_today

Updated On:

Description

Randomly the Citrix Studio console takes a long time to list Catalogs or Delivery group. The behavior appears if we open the Citrix Studio Console into Delivery Controller server or another server with Citrix Studio console installed. Other tabs in Studio like DG, Administrators, works fine and can open quickly.

In CDF, we can see:


Line 2164: 2129,2,2018/05/31 12:49:18:90556,14560,7720,-1,Xendesktop Management Console,_#dotNet#_,0,,1,CDF_NET_ERROR,"Xendesktop Management Console:1:1:GetConfiguredComponentListScript(45): Failed to collect a list of configured components. Error: System.NullReferenceException: Object reference not set to an instance of an object. 
Line 17428: 16552,0,2018/05/31 12:49:32:62853,11088,7512,0,ConfigurationLog,_#dotNet#_,0,,1,CDF_NET_ERROR,"ConfigurationLog:1:1:Called by <domain/user-name> who is not a known principal","" 
Line 33223: 32165,2,2018/05/31 12:50:01:34692,4880,14436,0,BrokerFiltering,_#dotNet#_,0,,1,CDF_NET_ERROR,"BrokerFiltering:1:1:BrokerSDKLogic.GetChbCommon: Unexpected exception System.NullReferenceException: Object reference not set to an instance of an object. 
Line 59422: 57911,1,2018/05/31 12:51:04:43976,840,14436,0,BrokerFiltering,_#dotNet#_,0,,1,CDF_NET_ERROR,"BrokerFiltering:1:1:BrokerSDKLogic.GetChbCommon: Unexpected exception System.NullReferenceException: Object reference not set to an instance of an object. 
Line 77722: 75844,3,2018/05/31 12:52:07:32939,80,14436,0,BrokerFiltering,_#dotNet#_,0,,1,CDF_NET_ERROR,"BrokerFiltering:1:1:BrokerSDKLogic.GetChbCommon: Unexpected exception System.NullReferenceException: Object reference not set to an instance of an object. 
Line 100476: 98091,0,2018/05/31 12:53:10:73868,2676,14436,0,BrokerFiltering,_#dotNet#_,0,,1,CDF_NET_ERROR,"BrokerFiltering:1:1:BrokerSDKLogic.GetChbCommon: Unexpected exception System.NullReferenceException: Object reference not set to an instance of an object. 
Search "t714253" (3 hits in 1 file)

Resolution

Check the no. of rows from the table "DesktopUpdateManagerSchema.PendingImageDeletes".
For this we can run -- select * from DesktopUpdateManagerSchema.PendingImageDeletes on the site database. 

After this on powershell of controller, please run: 
asnp citrix.* 
Get-Provtask -Active $true >c:\true.txt 
Get-Provtask -Active $false >c:\false.txt 

Check the entries in the false text files. If we see a lot of entries, execute:

Get-ProvTask -active $false | Remove-ProvTask 
 

Problem Cause

Large no. of deleted/pending prov tasks present in the database.