Error "Cannot start desktop" when launching after connecting via NetScaler Gateway

Error "Cannot start desktop" when launching after connecting via NetScaler Gateway

book

Article ID: CTX235855

calendar_today

Updated On:

Description

Error "Cannot start desktop" when launching after connecting via NetScaler Gateway. This error does not occur when bypassing the NetScaler Gateway by browsing directly to StoreFront, and the desktops launch without any problems.

Resolution

-Corrected the typo in both of the STAs in StoreFront, and propagated the changes, so that the StoreFront servers are now able to properly resolve the STA server hostnames.
-This resolved the issue. We can now launch the desktops without error.

Problem Cause

StoreFront unable to resolve the STA server hostnames.

-Checked the StoreFront server event viewer and found the following messages, regarding the STAs:
     The server name <STA_SERVER_HOSTNAME> cannot be resolved.  the specified Secure Ticket Authority could not be contacted and has been temporarily removed from the list of active services.
-Compared the server names to the STA servers that are configured on the NetScaler Gateway, and found that there is a typo in the names of both STA servers where they are configured in StoreFront.
-This causes the StoreFront servers to not be able to resolve the STA server hostnames correctly.

User-added image

User-added image

User-added image