Error: "Cannot Complete Your Request" Due to DNS Misconfiguration on Citrix ADC

Error: "Cannot Complete Your Request" Due to DNS Misconfiguration on Citrix ADC

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Article ID: CTX235843

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Updated On:

Description

The following error is displayed due to DNS misconfiguration on NetScaler:
Cannot Complete Your Request

Resolution

Complete the following steps to troubleshoot this issue:

  1. If you are load balancing StoreFront, then Open the command prompt from the testing machine and ping StoreFront base URL FQDN to confirm if it is resolving to the load balancing IP address.
  2. Verify if FQDN of STA server is resolvable. If not, change the STA server FQDN to IP address on StoreFront and on ADC (Citrix Gateway vserver > STA). For more information refer to Citrix Documentation - Configuring the Secure Ticket Authority on Citrix Gateway .

Problem Cause

This issue is caused due to DNS misconfiguration on Citrix ADC.

Issue/Introduction

The following error is displayed due to DNS misconfiguration on NetScaler: Cannot Complete Your Request

Additional Information