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Article ID: CTX235766
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Description
After upgrading the two Delivery Controllers from XenDesktop 7.14 to XenDesktop 7.17 user is unable to launch apps after about 45 minutes from one of the Delivery Controllers brokering the connections.
Resolution
Reset Perfmon counters on the affected Delivery Controller. Refer to CTX133320 - Citrix Broker Service fails to initialize XML services with the error: "'Input string was not in a correct format".
Other Potential Action Items in the event of re-occurrence:
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Disable DB Mirroring
Remove affected controller from the site and re-add (https://docs.citrix.com/en-us/xenapp-and-xendesktop/7-6/xad-controller-intro/xad-controller-change.html)
Reference Documents
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https://support.citrix.com/article/CTX133320 - Reset Perfmon Counters https://docs.citrix.com/en-us/xenapp-and-xendesktop/7-6/xad-controller-intro/xad-controller-change.html - Remove a Controller https://support.citrix.com/article/CTX127359 - How to Configure XenDesktop for SQL Database Mirroring
https://support.citrix.com/article/CTX132461 - Applied Step 4 - XML request set to True (Error: "An error occurred while making the requested connection")
Problem Cause
Likely Cause: On the Controller server, perfmon fails to upload the basic System counters such as memory, I/O, and Process. (
https://support.citrix.com/article/CTX133320)
Other Possible Causes:
1. XML Trust was set to False
2. DB Mirror did not get automatically configured properly on the affected Del.Controller when it got upgraded
Issue/Introduction
Unable to launch apps brokered from one of the DC's with event id 2013 - Citrix.Fma.Sdk.Dal.SqlTxProvider.Open