Black screen is displayed while launching a published applications hosted on Windows Server 2016

Black screen is displayed while launching a published applications hosted on Windows Server 2016

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Article ID: CTX235681

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Updated On:

Description

Warning: If you are using Azure Active Directory (AAD), do not make the registry change described in this article. Making this change may cause session launch failures for AAD users.

When you launch a published application on Microsoft Windows Server 2016, a black screen might appear for several seconds before the application becomes visible.

Citrix and Microsoft have identified an issue when launching seamless applications from a Server VDA running Windows Server 2016. When a user launches an application published from this VDA, Citrix Receiver displays a black screen covering the work space of the monitor for several seconds before launching the application.

Environment

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Resolution

Citrix and Microsoft have worked together to deliver code fixes for both Windows Server 2016 and XenApp.

Microsoft has released KB4034661 https://support.microsoft.com/en-in/help/4034661/windows-10-update-kb4034661.
We have addressed this issue in XenApp 7.15 LTSR under LC7947 https://docs.citrix.com/en-us/xenapp-and-xendesktop/7-15-ltsr/whats-new/fixed-issues.html

Note: Both fixes are required to resolve this issue along with below registry settings.

Path : HKLM\SOFTWARE\Citrix\Citrix Virtual Desktop Agent
Value Type = REG_DWORD
Value Name = DisableLogonUISuppression 
Data : 0 - Feature enabled (LOGON UI SUPPRESSION – No Black Screen)

1 - Feature disabled (You will see the Black screen issue).


Problem Cause

Citrix and Microsoft identified issues surround the ThinWire remoting of the LogonUI component in Server 2016.

Issue/Introduction

XenApp/XenDesktop : Black Screen Is Displayed While Launching A Published Applications From Windows Server 2016 VDA

Additional Information

Troubleshooting Gray or Black Screen