book
Article ID: CTX235513
calendar_today
Updated On:
Description
Citrix is committed to ensuring compatibility with the latest VMware Hypervisor releases. VMware released vSphere 6.7 in April 2018.
Note:
- This is a live article, and is updated as and when the new information becomes available.
- For Current Release, vSphere 6.7 is supported with Virtual Apps and Desktops (XenApp & XenDesktop) v7.18 or newer and Provisioning Services v7.18 or newer.
- For Long Term Service Release, vSphere 6.7 is supported with Virtual Apps and Desktop (XenApp & XenDesktop) v7.15 LTSR CU3 or newer and Provisioning Services v7.15 LTSR CU3 or newer.
- For detailed list of Citrix products and supported Hypervisors, refer to CTX131239 Supported Hypervisors for XenDesktop and Provisioning Services
- vSphere 6.7 is not supported with Virtual Apps and Desktops (XenApp & XenDesktop) v7.6 LTSR
Known Issues
The following information outlines the issues and their solutions:
Issue 1
Issue Description
Citrix Machine Creation Service (MCS) fails to create MCS Catalog on vSphere 6.7 with error “There are no master images associated with machine Catalog” when EFI is configured as Firmware option for master image template.
[PMCS-2019]
Problem Cause
The issue is caused by new changes in vSphere 6.7. This issue is seen only with Virtual Apps and Desktops (XenApp/XenDesktop) versions up to 7.17.
Solution
This issue is fixed in Virtual Apps and Desktops (XenApp/XenDesktop) 7.18 and 7.15 LTSR CU3.
Issue 2
Issue Description
Citrix Provisioning Services (PVS) throws an error “Cannot connect to hypervisor at https:<hostname>:failed to connect to remote server” while establishing connection with vCenter 6.7
[PVS-3597]
Problem Cause
The issue is caused by new changes in vSphere 6.7. This issue is seen only with Provisioning Services versions up to 7.17.
Solution
This issue is fixed in Provisioning Services 7.18 and 7.15 LTSR CU3.
Issue 3
Issue Description
Configuring vSphere 6.7 for a new hosting connection on XenDesktop 7.6 LTSR fails with error “The supplied address for the computer resource is invalid….”
[LCM-4323]
Problem Cause
The issue is caused due to new changes in vSphere 6.7
Solution
There is no solution. vSphere 6.7 is not supported with 7.6 LTSR.
Issue 4
Issue Description
The window titled “Certificate Authentication” is not shown while creating a vSphere 6.7 hypervisor host connection with XenDesktop.
[STUD-3091]
Problem Cause
The issue is caused by new changes in vSphere 6.7
Solution
This issue is fixed in Virtual Apps & Desktops (XenApp/XenDesktop) 7 1811 and 7.15 LTSR CU3.
Workaround
Users on Virtual Apps & Desktops (XenApp/XenDesktop) 7.18 & 1808:
Administrators can push the vCenter server certificate manually to the Delivery Controller server by following steps outlined on https://support.citrix.com/article/CTX138640.
Issue 5
Issue Description
On Virtual Machine's (hosted on vSphere) with VMWare tools (10.3.2.x or above) installed, a failure may be seen with standalone installation of Storefront or while upgrading Storefront part of Virtual Apps and Desktops 7 1906 OR 1909. An error ‘An error occurred with the operation for Storefront’ may be seen.
[WSP-4895]
Solution
This issue is fixed with VMtool v11.0. Upgrade VMWare tools to v11 or newer before attempting to install/upgrade of Storefront.