Citrix Cloud XenApp XenDesktop - unable to delete machine catalogs.
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Article ID: CTX235501
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Updated On:
Description
Citrix Cloud XenApp XenDesktop - unable to delete machine catalogs.
The catalogs are either in pending state or are hung and are not getting error-ed out.
Environment
This software application is provided to you as is with no representations, warranties or conditions of any kind. You may use and distribute it at your own risk. CITRIX DISCLAIMS ALL WARRANTIES WHATSOEVER, EXPRESS, IMPLIED, WRITTEN, ORAL OR STATUTORY, INCLUDING WITHOUT LIMITATION WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, TITLE AND NONINFRINGEMENT. Without limiting the generality of the foregoing, you acknowledge and agree that: (a) the software application may exhibit errors, design flaws or other problems, possibly resulting in loss of data or damage to property; (b) it may not be possible to make the software application fully functional; and (c) Citrix may, without notice or liability to you, cease to make available the current version and/or any future versions of the software application. In no event should the software application be used to support ultra-hazardous activities, including but not limited to life support or blasting activities. NEITHER CITRIX NOR ITS AFFILIATES OR AGENTS WILL BE LIABLE, UNDER BREACH OF CONTRACT OR ANY OTHER THEORY OF LIABILITY, FOR ANY DAMAGES WHATSOEVER ARISING FROM USE OF THE SOFTWARE APPLICATION, INCLUDING WITHOUT LIMITATION DIRECT, SPECIAL, INCIDENTAL, PUNITIVE, CONSEQUENTIAL OR OTHER DAMAGES, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. You agree to indemnify and defend Citrix against any and all claims arising from your use, modification or distribution of the software application.
Resolution
Please follow the following steps to remove the machine catalog:
1. Make sure that there are no machines in the machine catalog. Remove if there are any.
2. Install powershell SDK on any machine in the same domain/vnet (Note: do not install on a Cloud Connector or VM with Citrix software present) using the following:
https://www.citrix.com/blogs/2016/07/01/introducing-remote-powershell-sdk-v2-for-citrix-cloud/.
http://download.apps.cloud.com/CitrixPoshSdk.exe (download link) .
3. Once installed, run the following command in Powershell (run as administrator) to remove the catalog:
> asnp Citrix*
> Get-XDAuthentication
(a new page should pop up asking for your citrix cloud credentials. Please login here and get back to the windows powershell)
>Remove-BrokerCatalog -Name "CatalogName"
4. Once the command completes without any thrown errors then refresh the Studio console to confirm the catalog has been removed.
If there are any throw errors or additional questions with the above steps please reach out to Citrix Support at 1-800-4-Citrix
Problem Cause
Possible cause: the connection between the Connector and DDC could be broken at the time of deleting the catalogs.
Another possible cause: Locked identity pool
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