Published app sessions not ending due to WEM UI agent appearing in the system tray

Published app sessions not ending due to WEM UI agent appearing in the system tray

book

Article ID: CTX235429

calendar_today

Updated On:

Description

In configuration sets where the WEM UI agent is configured to launch for both server desktop and app sessions, published app sessions remain connected after closing the published app. Checking the Connection Center in Citrix Receiver, the WEM agent icon is listed as the only connection back to the ICA session on the XenApp host server.

Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Resolution

To resolve the problem, perform any one of the following solutions:

Solution 1

Checking the "Execute Only Cmd Agent in Published Applications" checkbox will utilize a Command Line based agent that does not show an icon in the system tray.

Solution 2

  • If the UI agent must be utilized for a specific reason, setting the seamless flag to disable the System Tray agent (by creating a "SeamlessFlags" DWORD with a value of 0x20 located under HKLM\System\CurrentControlSet\Control\Citrix\wfshell\TWI) will stop the WEM agent and all other System Tray icons from the ICA session from being sent to the System Tray of the endpoint machine where Receiver is connecting from.
  • This can either be done manually by editing the registry, or by utilizing the Seamless Configuration Helper Tool, or FarmTWIHelper as it is also referred to.

Solution 3

The "LogoffCheckSysModules" registry entry can also be utilized as well. This needs to be created under the same key as the previously mentioned "SeamlessFlags" entry and is a String Value entry (REG_SZ) that needs to have its value populated with the process name "VUEMUIAgent.exe".
This will cause the agent to exit upon closing the published application and will allow the session to gracefully log off the user.

Problem Cause

WEM UI agent was passing through to the local system tray from the ICA session, leaving the session in an active state even though the published application was closed.

Additional Information