Citrix Gateway STA Server Binding state with FQDN stays down
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Article ID: CTX235273
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Description
- APP / Desktop Launch Failures being observed via Citrix Gateway
- Upon investigation we saw the STA Servers were down. (FQDN based)
- There was no issue with DNS Resolution on reachability.
- FQDN based STA servers were replaced with IP Based Which brought the STA Servers UP
- Issue was observed immediately after a failover.
- Checking the /var/newnslog it was found that following STA Counters were incrementing.
#nsconmsg -K /var/nslog/newnslog -d current | grep csg_sta_primary_validate_fail Index rtime totalcount-val delta rate/sec symbol-name&device-no&time 0 144341 33 1 0 csg_sta_primary_validate_fail Mon May 7 22:23:01 2018 1 2290689 34 1 0 csg_sta_primary_validate_fail Mon May 7 23:01:12 2018 2 878617 35 1 0 csg_sta_primary_validate_fail Mon May 7 23:35:21 2018 3 671517 36 1 0 csg_sta_primary_validate_fail Mon May 7 23:46:32 2018 4 81586 37 1 0 csg_sta_primary_validate_fail Mon May 7 23:47:54 2018Also you can check for the stats of counter to identify the issue:
#nsconmsg -K /var/nslog/newnslog -d stats | grep csg_sta_primary_validate_fail32665 0 58 csg_sta_primary_validate_fail
Resolution
IssueID: #636053
This is fixed in following available versions, our recommendation is to upgrade to GA of the version you choose to upgrade to. 11.0 Build 70.16 or Higher, 11.1 Build 55.13 or Higher, 12.0/12.1 Any Build.
Problem Cause
Known Issue on builds 11.0_66.X and lower.
Issue/Introduction
STA Server configured bound to Citrix Gateway with https://FQDN not working after failover and stays down, regardless of the STA servers actual state being UP.
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