Personal vDisk Image update failing with error: "There is not enough free space in the Personal vDisk storage. Expand Personal vDisk storage to provide more space"
book
Article ID: CTX235111
calendar_today
Updated On:
Description
We observe following errors and symptoms:
1) Personal vDisk inventory process completes successfully. However, Personal vDisk Image update failing with error: "There is not enough free space in the Personal vDisk storage. Expand Personal vDisk storage to provide more space".

2) We observe below error in Citrix Studio:
Error code 18. There is not enough free space available on the personal vDisk drive when performing an image update operation. Expand personal vDisk storage or remove unused files to free space in the personal vDisk storage. The image update should restart after next reboot.
3) We encounter the same error even after increasing the Personal vDisk size.
4) Resetting the Personal vDisk may help.
Environment
This software application is provided to you as is with no representations, warranties or conditions of any kind. You may use and distribute it at your own risk. CITRIX DISCLAIMS ALL WARRANTIES WHATSOEVER, EXPRESS, IMPLIED, WRITTEN, ORAL OR STATUTORY, INCLUDING WITHOUT LIMITATION WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, TITLE AND NONINFRINGEMENT. Without limiting the generality of the foregoing, you acknowledge and agree that: (a) the software application may exhibit errors, design flaws or other problems, possibly resulting in loss of data or damage to property; (b) it may not be possible to make the software application fully functional; and (c) Citrix may, without notice or liability to you, cease to make available the current version and/or any future versions of the software application. In no event should the software application be used to support ultra-hazardous activities, including but not limited to life support or blasting activities. NEITHER CITRIX NOR ITS AFFILIATES OR AGENTS WILL BE LIABLE, UNDER BREACH OF CONTRACT OR ANY OTHER THEORY OF LIABILITY, FOR ANY DAMAGES WHATSOEVER ARISING FROM USE OF THE SOFTWARE APPLICATION, INCLUDING WITHOUT LIMITATION DIRECT, SPECIAL, INCIDENTAL, PUNITIVE, CONSEQUENTIAL OR OTHER DAMAGES, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. You agree to indemnify and defend Citrix against any and all claims arising from your use, modification or distribution of the software application.
Resolution
This issue is resolved in LC9439. Please contact Citrix Support for the same.
Problem Cause
This issue is usually seen while installing Service Packs, Cumulative Updates or Windows version update. These updates make changes to a large number of files in the windows OS. Personal vDisk tries to log each of these change and hence ends up creating a huge log file during the Image update process. It is this log file that brings the Available free space below Required free space. Now, at the time of Merging VHD, Personal vDisk does another check on the available space and compares it to required free space. Hence the image update fails due to shortage of Free Space.
Issue/Introduction
Personal vDisk inventory process completes successfully. However, Personal vDisk Image update failing with error: "There is not enough free space in the Personal vDisk storage. Expand Personal vDisk storage to provide more space". We encounter the same error even after increasing the Personal vDisk size. Resetting the Personal vDisk may help.
Was this article helpful?
thumb_up
Yes
thumb_down
No