Microsoft releases software updates for Windows 10 twice a year through the Semi-Annual Channel. On 2nd October 2018, Microsoft released its latest Semi-Annual Channel release for Windows 10 called 'October 2018 Update' (v1809).
This article is intended to capture known issues with Windows 10 v1809 that have been identified so far through Citrix internal testing and customer reports.
Issue Description
The mouse cursor is distorted or may disappear at times when a published application or VDA is launched in full screen on multi-monitor setup with high DPI/Resolution.
[RFWIN-7040]
Problem Cause
Monochrome custom cursors created via CreateCursor() can be distorted on multi-monitor setups with mixed DPI in Windows 10.
Solution
Issue Description
Print command from inside an ICA session of Windows 10 v1809 client fails to print using mapped Citrix UPS configured XPS Printer.
[HDX-13664]
Problem Cause
XPS Viewer is not available on Windows 10 v1803 and later versions by default. It is available as a Feature on Demand.
Solution
To install XPS Viewer, follow the below steps:
Note:
Issue Description
Upgrade from Windows 10 v1803 to v1809 fails if Citrix User Profile Manager (UPM) is installed.
[TPV-1431]
Problem Cause
The upgrade fails with an error message “error during MIGRATE_DATA operation”.
Solution
The Microsoft KB4343909 resolves this issue. Install KB4343909 OR its replacement on v1803 prior to upgrade of Windows 10 v1809.
Issue 6
Issue Description
Citrix User Profile Manager (UPM) stops working after Windows 10 is upgraded to v1809.
[TPV-1307]
Problem Cause
The upgrade process is removing some of the registry entries related to UPM.
Solution
This issue is fixed with the Microsoft's March 2019 Updates for Windows 10. Install the respective March 2019 update OR its replacement on your existing Windows 10 version before upgrading to Windows 10 v1809.
Issue 7
Issue Description
Mouse pointer is not visible within a v1809 HDX 3D pro session. All operations inside the session are to be performed by keyboard using shortcuts. This issue is seen with Citrix XenApp/XenDesktop 7.15 only. This issue is not seen with later versions of XenApp/XenDesktop.
[LCM-4951]
Problem Cause
A change in mouse functionality API's is causing this issue.
Solution
Issue Description
After HDX 3D Pro VDA is upgraded from Windows 10 v1803 to v1809, the policy "Use hardware encoding for video codec" is not in effect and Hardware Encoding is disabled. The Registry information related to BitMap Provider is also not as expected post upgrade.
[LCM-4955, LCM-4956]
Solution
NvFBC has been deprecated as per the bulletin by NVIDIA.
Issue 9
Issue Description
Pass-Through Authentication (SSON) fails to work when Windows 10 is upgraded to v1809 with Workspace App installed.
[TPV-1916]
Problem Cause
While upgrading to v1809, few registry entries required by SSON gets removed under HKLM > System > CurrentControlSet > Control > NetworkProvider.
Solution
This issue is no longer seen if KB4490481 is present on target OS (v1809). If using ISO, while upgrading to v1809, check the option of obtaining updates during upgrade. This will include KB4490481 during upgrade.
If the fix is not accessible, users may manually add the registry keys (Workaround 1) OR run a Power Shell script (Workaround 2) that adds the registry entries that were deleted by the installer.
Workaround 1:
Caution! Refer to the Disclaimer at the end of this article before making changes to Registry
Right click on Start button and choose Run
Type regedit and click OK.
Browse to HKEY_LOCAL_MACHINE > SYSTEM > CurrentControlSet > Services.
Right-click on Services and choose New > Key.
Enter value PnSson for the new key and click OK.
Right-click the key PnSson for and choose New > DWORD 32 bit, enter IsEnabled and set Value data 1
Right-click the key PnSson for and choose New > DWORD 32 bit, enter Type and set Value data 4
After adding the keys and values, it should appear like below:
Right-click NetworkProvider > New > String Value, enter Name and set Value data Citrix Single Sign-on.
Right-click NetworkProvider > New > String Value, enter ProviderPath and set Value data to below value:
C:\Program Files (x86)\Citrix\ICA Client\x64\pnsson.dll on 64 bit Machine
C:\Program Files\Citrix\ICA Client\pnsson.dll on 32 bit Machine
Note: If Workspace App is installed in Custom location, the above values should be changed accordingly to $InstallPath$\ICA Client\... Example: If install path is c:\Citrix then the value should be C:\Citrix\ICA Client\....
Right-click NetworkProvider > New > DWORD 32 bit, enter Class and set Value data 2.
After adding the keys and values, it should appear like below:
Browse to HKEY_LOCAL_MACHINE> SYSTEM> CurrentControlSet> Control> NetworkProvider> Order
Right Click on ProviderOrder and Select Modify.
Add ,Pnsson to the end of the current value in the registry.
After adding the keys and values, it should appear like below:
Browse to HKEY_LOCAL_MACHINE> SYSTEM> CurrentControlSet> Control> NetworkProvider> HwOrder
Right Click on ProviderOrder and Select Modify.
Add ,Pnsson to the end of the current value in the registry.
After adding the keys and values, it should appear like below:
Workaround 2:
Users could run the Power Shell script that adds the above entries. Download the attachment.zip file, extract it to a folder and run Receiver_SSON.PS1. This script will add the registry entries based on the Receiver install location. It also retains services registered with Microsoft Network Provider and appends PnSson value. Users are advised to test the script before using it in a production environment.
Issue 10
Issue Description
WEM cannot pin apps to taskbar in Windows 10 v1809
[WEM-3257]
Problem Cause
After pinning apps to taskbar and refreshing the agent, the apps are still not shown on the VDA.
Solution
Issue Description
Printers part of Universal Print Server are no longer mapped after Windows 10 is upgraded to Windows 10 v1809. This issue is not seen with fresh install of Windows 10 v1809.
[LCM-5677]
Solution
There is no solution. Support for custom print drivers have been deprecated by Microsoft.
Issue Description
Citrix Workspace Environment Management (WEM) Agent fails to work when Windows 10 is upgraded to v1809.
[TPV-1184]
Problem Cause
The ‘Norskale’ key under [HKLM -> System -> CurrentControlSet -> Control] is removed during the upgrade to v1809.
Solution
Citrix is working with Microsoft to resolve this issue. To restore functionality, users could uninstall WEM Agent on the upgraded machine, reinstall and reconfigure.
Issue Description
"The trust relationship between this workstation and the primary domain failed" error occurs after MCS VDAs are upgraded to Windows 10 v1809. This issue is not seen with fresh install of Windows 10 v1809.
Problem Cause
The dependency of "Citrix Pvs VMs agent" service is lost by the upgrade. See CTX251326 in detail.
Solution
Citrix is working with Microsoft to resolve this issue.
Workaround
Caution! Refer to the Disclaimer at the end of this article before making changes to Registry.
Issue Description
Lync 2013/Skype for Business 2015 may crash after receiving a shared file if Windows 10 v1803 with Citrix LTSR VDA 7.15 & Lynch 2013/Skype for Business 2015 was upgraded to v1809.
Problem Cause
Some of the registry keys required by Lync/Skype for Business is getting blown during upgrade.
Solution
We are working with Microsoft to resolve this issue. As a work around, users may manually add the registry key by following below steps.
Caution! Refer to the Disclaimer at the end of this article before making changes to Registry.