NetScaler MAS Reports High Memory Utilization

NetScaler MAS Reports High Memory Utilization

book

Article ID: CTX234860

calendar_today

Updated On:

Description

User receives alerts related to high memory usage however they do not observe any latency or performance related issue. From var/log ns.log we see logs related to high  memory and from mps_service.log we see messages related to out of shared memory.

Tuesday, 20 Mar 18 14:26:18.845 +1100 [Debug] [Main] InsightUtil::refresh_cluster_info_map refreshed 1 objects.
Tuesday, 20 Mar 18 14:27:18.888 +1100 [Error] [Main] DB InsightUtil::update_url_name_map_info::ODBC handle exception: SQLExecute()
Requested SQL statement: SELECT distinct(id), http_req_url FROM af_url_map WHERE ((rpt_sample_time > -300 ) AND (rpt_sample_time < 1521516438 ) ) GROUP BY id, http_req_url
Native SQL statement: SELECT distinct(id), http_req_url FROM af_url_map WHERE ((rpt_sample_time > -300 ) AND (rpt_sample_time < 1521516438 ) ) GROUP BY id, http_req_url
: Connection:Not applicable
Server:Not applicable

ODBC Diagnostic record #1:

SQLSTATE = 53200
Native Error Code = 7
ERROR: out of shared memory;
Error while executing the query

Resolution

To resolve this issue increase the memory to 32 GB instead of 16 GB.


Problem Cause

Enough memory was not assigned to the MAS instance.

Issue/Introduction

User sees memory usage reaching upto 80%, however we do not observe any latency or performance related issue.

Additional Information

Citrix Documentation - Installing NetScaler MAS on VMWare ESXi