Unable to supersede or re-activate a storage in a Hosting Unit
book
Article ID: CTX234655
calendar_today
Updated On:
Description
When attempting to supersede a storage in a Hosting Unit (also known as Resources) the changes do not seem to be applied.
The same behavior can be seen when trying to re-activate a previously superseded storage.
Basically the changes done to the Storage Status are not saved.
This behavior can be observed by performing the following steps:
- On Citrix Studio click on an existing Hosting Unit to select it and then click on "Edit Storage" in the actions pane
- The Edit Storage Window appears and it shows all the storages defined in this Hosting Unit
- Remove the check-mark from the checkbox to the left of the Storage Name to instruct XenDesktop not to use this Storage. This sets the Storage to Superseded status
Note: The same behavior can be observed when adding the check-mark to a previously superseded storage to make it active again. - Click Ok
- Once again select the same Hosting Unit and then click on "Edit Storage" in the actions pane
- Notice that the changes were not saved and the Storage still has the same status it did before (either "In Use" or "Superseded)
Resolution
There are two possible solutions for this issue.
- Rename the Storage on the Hypervisor side to the original name that it had when the Hosting Unit was created.
- Create a new Hosting Unit, selecting the affected Storage, and create a new Catalog of Machines using this new Hosting Unit
Problem Cause
This issue can happen when the Storage has been renamed on the Hypervisor side.
Was this article helpful?
thumb_up
Yes
thumb_down
No