Refresh of WEM agent in admin console fails with error "Some of the requested actions may not have been executed properly"
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Article ID: CTX234539
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Updated On:
Description
When attempting to refresh the agents in any way or otherwise perform actions against an agent in the Administration node of the WEM Admin Console, the following message is seen in the bottom right corner: "Some of the requested actions may not have been executed properly."
The WEM Agents being used are PVS provisioned targets with multiple NICs, and the primary NIC is used strictly for PVS streaming while additional NICs are for all other network communication.
Resolution
Providing the default gateway on the base vDisk level or pushing out via DHCP scope will allow for network communication over the primary NIC.
Because of the need at times to follow PVS best practices (where only the PVS streaming of the image to the targets and no other traffic is allowed on the primary NIC) conflicts with the requirements of the WEM agent.
Configure a rule/policy on the default gateway to allow only the required ports for WEM communication for that specific network to be permitted.
All other communications can then be denied via the same rule/policy so the second NIC is the only way for additional required network communications.
Problem Cause
WEM agents by design bind to the broker and communicate via the primary NIC on the host machine. The default gateway was not configured for the primary NIC for VMs hosting the WEM agents, which explains the communication failure strictly over that NIC.
Additional Information
Best Practices for Configuring Provisioning Services Server on a Network: https://support.citrix.com/article/CTX117374
Required Ports for Workspace Environment Management communication: https://docs.citrix.com/en-us/workspace-environment-management/current-release/reference/ports.html
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