Timezone on Clients Running Windows 10 Changes in Citrix VDI from US-EDT to "Caracas" time

Timezone on Clients Running Windows 10 Changes in Citrix VDI from US-EDT to "Caracas" time

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Article ID: CTX234415

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Updated On:

Description

Current Timezone is UTC - 05:00 (US & Canada) - When end users log into a Citrix VDI Windows 7 desktop using a Windows 10 client/host the timezone switches to UTC - 04:00 (Caracas).

This causes problem with Calendar appointments getting booked in the wrong time zone and being 1/2 hour behind. If we test the same logging/client using Windows 7 Pro device/host the timezone is correct. Same goes from a MacBook Pro. Why is Windows 10 tripping a different timezone. The problem occurs in both live environment and in test environment.

Resolution

Upgraded Receiver for HTML5 version in the Storefront server from version 2.3 to version 2.6.5.

Also, as a workaround: If Receiver for HTML5 stays in version 2.3 then disable "Automatically adjust clock for Daylight Savings" in the VDI (not longer needed in this use case since upgrade fixed the issue).


Problem Cause

LC7818 In a desktop session, when you enable Automatically adjust clock for Daylight Saving option in the Time zone settings, the displayed time zone is incorrect.

https://docs.citrix.com/en-us/receiver/html5/current-release/about/fixed-issues.html

Issue/Introduction

In the Windows 10 client machines Timezone redirection defaults to "Caracas" time zone even though Data Center and users are in Toronto, CA which uses US-EDT. Issue doesn't occur on MAC end point devices

Additional Information

https://docs.citrix.com/en-us/receiver/html5/current-release/about/fixed-issues.html