Unable to access XenApp through StoreFront, getting an Error - " Your logon has expired, please logon again to continue "

Unable to access XenApp through StoreFront, getting an Error - " Your logon has expired, please logon again to continue "

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Article ID: CTX234288

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Updated On:

Description

Unable to authenticate to Storefront server and getting error "Your logon has expired. Please log on again to continue"

Resolution

Used the base URL for store because a certificate is using base url in subject name.

Example: 

Base URL : https://apps.abc.com/

StoreURL : http://xyz.citrixresources.local/Citrix/store

Subject Name in Certificate : https://apps.abc.com/


Problem Cause

Base URL and Store URL are different.