PVS target devices are randomly getting unregistered and going down in PVS console

PVS target devices are randomly getting unregistered and going down in PVS console

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Article ID: CTX234126

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Updated On:

Description

Target devices show up and running in hypervisor console
Targets show down in PVS console and get unregistered intermittently 
Restart fixes the issue 
During the time of issue, ping to the target device works,but RDP fails

Resolution

  1. Find machine in Citrix Studio or Director Web UI and turn on maintenance mode.

  2. Log into any server that has the Hyper-V Manager and locate affected VM. Right click and select Turn Off…

  3. Log into PVS server, open the Provisioning Services Console and expand the following: Farm>Sites>city>Device Collections then click on XenApp-Production

  4. Highlight the corresponding session host and right click. Mouse over Target Device then click Shutdown

  5. Click Action>Refresh to refresh the list of session host. This may need to be repeated a few times until the green check mark is gone from next to the session host name

  6. Right click on the session host and mouse over Active Directory the click Reset Password for Machine Account

  7. Now right click again and select Boot

  8. Once that is successful go to the Hyper-V Manager and turn on the corresponding VM.

  9. Ensure machine is booted and working normally. 

  10. Then go back to Citrix Studio or Director Web UI and turn off maintenance mode.


Problem Cause

Issue is with duplicate IP issue or AD locking the machine account.