Bluefin (Ingenico) IPP320 failing to communicate with Sage Exchange Desktop via ICA Channel Serial COM Port

Bluefin (Ingenico) IPP320 failing to communicate with Sage Exchange Desktop via ICA Channel Serial COM Port

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Article ID: CTX233973

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Updated On:

Description

Serial COM port redirected device Bluefin Ingenico IPP320 with encryption, fails to complete the communication with the Sage Payment Solutions.

Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Resolution

Configuration consists of 3 parts, Citrix Policies, VDA registry keys and client registry keys.
 
To configure Citrix Polices:
  1. Navigate to any of the Delivery Controllers in the Site and open Citrix Studio;
  2. In Citrix Studio navigate to the Policies console;
  3. In the Polices console, create new polices or add to existing policy following settings:

3.1 Select Enabled for “Auto Connect client COM ports”

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3.2 Select Allowed for “Client COM port redirection”

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3.3 If the policies shows “Disabled”, make sure you enable the policy.

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On the VDA, using the information from the following Citrix document https://docs.citrix.com/en-us/xenapp-and-xendesktop/7-8/policies/policies-settings-reference/xad-policies-settings-deprecated.html, create following registry keys:
“AllowComPortRedirection”, and
“AutoConnectClientComPorts”.
 
On the client machines, please create following registry keys:
HKEY_LOCAL_MACHINE\SOFTWARE\Citrix\ICA Client 
Name: CommBufferSize
Type: REG_DWORD
Data: 2048 (maximum value)
As per https://support.citrix.com/article/CTX138197.

HKEY_LOCAL_MACHINE\SOFTWARE\{Wow6432Node}\Citrix\ICA\Client\Engine\Configuration\Advanced\Modules\ClientComm
Name: WindowSize
Type: REG_SZ
Data: 2048 (maximum value)


Problem Cause

Server-side (VDA) buffer limit for single Serial COM segment being reached and causing applications to hang.

Additional Information

https://docs.citrix.com/en-us/xenapp-and-xendesktop/7-8/policies/policies-settings-reference/xad-policies-settings-deprecated.html
https://support.citrix.com/article/CTX138197