XenMobile: 500 Server Internal Error (exid:16200BC6AC0-503E3024D00ABC1E4C352FFA2DAD6AC0) when we click on Manage > User

XenMobile: 500 Server Internal Error (exid:16200BC6AC0-503E3024D00ABC1E4C352FFA2DAD6AC0) when we click on Manage > User

book

Article ID: CTX233928

calendar_today

Updated On:

Description

When you click Users tab on XenMobile server receiving error - 500 Server Internal Error (exid:16200BC6AC0-503E3024D00ABC1E4C352FFA2DAD6AC0)

 

Resolution

Delete the Duplicate entries from the Database to resolve the issue by Executing the below query in the XenMobile Server Database:
select * from dbo.KEYSTORE where name in (';AgUserAuthCredential=abc@example.com;') order by MODIFICATION_DATE desc
Note: Ensure that you take a back up of database before making any changes 

XenMobile Server gets exception  com.sparus.nps.spi.impl.KeyStoreHandlerImpl.getKeyStore method. Exception could be due to more than one unique certificate found for device under Database.


Problem Cause

Multiple certificate entry found in XenMobile Server

In the Xenmobile Server logs
2018-03-07T08:52:50.881-0500 | C1BA18C0DE305D4C  | ERROR | http-nio-14443-exec-85 | com.sparus.nps.ErrorFilter | Exception (exid:16200BC6AC0-503E3024D00ABC1E4C352FFA2DAD6AC0): org.springframework.dao.IncorrectResultSizeDataAccessException: query did not return a unique result: 2; nested exception is org.hibernate.NonUniqueResultException: query did not return a unique result: 2 

Issue/Introduction

This article summarizes the steps to follow if you are receiving the error "500 Server Internal Error (exid:16200BC6AC0-503E3024D00ABC1E4C352FFA2DAD6AC0)" when clicking on User tab in XenMobile