Zombie RDP session displayed in studio with username "-"
book
Article ID: CTX233920
calendar_today
Updated On:
Description
Zombie session displayed in studio with username "-".
Environment
Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.
Resolution
Workaround:Change Microsoft setting “Single Session Per User” policy to “Enabled”
Or change the following registry,
-
Start Registry Editor (by default, this is located at c:\windows\regedit.exe).
-
Go to the following registry key:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\TerminalServer
-
If the fSingleSessionPerUser value doesn't exist, create a new DWORD value named fSingleSessionPerUser
-
Open the fSingleSessionPerUser value. The possible values for this setting are as follows:
0x1
Force each user to a single sessionß-----We have to use this setting
-
Enter the new setting, and then click OK.
FIX:Apply private fix in LC8706 to fix this issue
Problem Cause
If “Single Session Per User” policy is set to “Disabled”, we actually provide NULL Sguids to BrokerAgent each time during RDP connection and reconnection, and this causes defunct session increases each time when user RDP to VDA.
Was this article helpful?
thumb_up
Yes
thumb_down
No