Message: "Please wait for the Local Session Manager" while launching the app, it gets stuck and then disappears.
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Article ID: CTX233913
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Updated On:
Description
You may see a message: "Please wait for the Local Session Manager" as shown below while launching the app, it gets stuck and then disappears.

Resolution
Please follow these steps to resolve the issue:
1. Delete the files and folder from following folder, to remove GP cache file:
- C:\ProgramData\Citrix\GroupPolicy
- C:\ProgramData\CitrixCseCache
- C:\Windows\System32\GroupPolicy\Machine\Citrix\GroupPolicy
- C:\Windows\System32\GroupPolicy\User\Citrix\GroupPolicy
2. Ensure that Caching on UPM store shared folder is disabled
Go to the file server that hosts the file share for UPM store
Go to the Shared folder.
Right click and go to Properties
Go to Sharing tab and click on Advanced Sharing
Click on Caching
Select "No files or programs from the Shared folder are available offline" and Click OK
Problem Cause
Launch attempts are held up on GP Client processing or User Profile Management. The actual issue is that the GP Client also known as CSEengine and that is getting an access denied while processing the Policies.
We would also see a lot of access denied error in the traces for logonredirector. This is an indication of the cache files issue.
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