Error: "500 Internal Server" when Clicking on 'Edit' for a Device on XenMobile

Error: "500 Internal Server" when Clicking on 'Edit' for a Device on XenMobile

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Article ID: CTX233828

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Updated On:

Description

When selecting a device under Manage r> Devices and clicking on Edit. Customer is receiving the Error:
500 Server Internal Error (exid:16**************************C0)

 

Resolution

Note: Please take a backup of the XenMobile server and the Database prior to making any changes.

Run below query and see if multiple certs per user is present in the keystore table:
USE [XenMobile_10]
GO
SELECT count([ALIAS]), name
FROM [dbo].[KEYSTORE]
group by name
having (count(alias) > 1)
GO


Run below query for name you obtained from above query to see certificate information:
select * from dbo.KEYSTORE where name in (';AgUserAuthCredential=abc@xyz.com;') order by MODIFICATION_DATE desc

To resolve this issue, remove duplicate certificate for device.


Problem Cause

User is experiencing Error <pre> <h1>500 Server Internal Error (exid:16200BC6AC0-503E3024D00ABC1E4C352FFA2DAD6AC0)<h1> </pre> for Device S/N xxxxxxx, as XenMobile server fail to retrieve unique keystore (certificate) information for ANDROID device ID xxxx (<serial number>) as DB contains duplicate certificate for device.

Issue/Introduction

When selecting a device under Manage r> Devices and clicking on Edit. Customer is receiving the Error: 500 Server Internal Error (exid:16**************************C0)