Enterprise Applications are not Auto Updated
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Article ID: CTX233664
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Updated On:
Description
Application marked as "Required" are not updating automatically on the device.
User is required to update the application from Secure Hub.
Resolution
Follow the below steps to resolve this issue.:
- Create and deploy the App Inventory policy to the Delivery Group.
- Set the APNS pool size value to 8.
- Add the custom server property on the XenMobile console.
Key: Custom Key
Key: force.server.push.required.apps
Value: TRUE
Display name: force.server.push.required.apps
Description: Force required apps to deploy
- Application updated immediately after hitting deploy on the Delivery Group.
Important: MDX-enabled required apps, including enterprise apps and public app store apps, upgrade immediately, even if you configure a MDX policy for an app update grace period and the user chooses to upgrade the app later.
Problem Cause
APNS issue and the App Inventory policy was not deployed due to which the XenMobile could not read the current version of the app on the device.
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