NetScaler License Allocation Failed After Reboot, Shows License as VPX(1)

NetScaler License Allocation Failed After Reboot, Shows License as VPX(1)

book

Article ID: CTX233486

calendar_today

Updated On:

Description

After reboot, NetScaler GUI shows License as VPX(1)

VPX(1) indicates that there is no license allocated to the NetScaler. Features will be disabled. CLI will not show license model. Virtual servers would be DOWN. Certificates might get uninstalled.

Resolution

Reallocate license with correct hostname, install on NetScaler.
Reboot.


Problem Cause

Hostname on license file and NetScaler is different To confirm the hostname and cause you can look into below logs  :
  1. Check hostname on NetScaler: show hostname
  2. Validate hostname on license file : /nsconfig/license cat license file name.
  3. Validate the expiry date in license file :
  4. In the screenshot, the license is valid till 1st May 2014
    User-added image
  5. Check the logs after reboot and search for licenses: cat ns.log and search for issue time
  6. Check license.log files for the cause of license allocation failure.
  7. This happens because even if the license expires, NetScaler continues to run until a reboot is performed,